Gitでの操作を取り消す

Gitでの取り消し操作には目的によりいくつかの方法がある。

ローカルの変更取り消し

変更はこれで全部取り消すことができるが、新規追加したファイルに関しては削除されない為、完全に元に戻したい場合は別途削除する必要がある。

 

addを取り消し

addの状態しか取り消されない為、変更も取り消したい場合はローカルの変更取り消し作業も行う必要がある。

 

commitを取り消し

modeのデフォルトは–mixedである為、変更したファイルはすべてそのままとなり、gitの履歴がだけが変わる。

変更したファイルも含めてすべて指定のcommit状態に戻したい場合は、modeに–hardを指定する。

また、–hardを指定した場合も新規追加のファイルは残ったままになっている為、完全に元に戻したい場合は別途削除する必要がある。

 

pushを取り消し

指定commitまでの変更を相殺するcommitを作成するというものなのでrevert後にpushすることでリモートが実質undoをしたような状態になる。

複数コミットを取り消したい場合は、-nオプションを指定する。

-nは–no-commitと同じオプションでその名の通り、自動でコミットをしないようにする。

 

VisualStudioで比較/マージにWinMergeを利用する

VisualStudioをMicrosoftのソース管理ツール(Team Foundation Server:TFS/Visual Source Safe:VSS)と統合して使用している場合に、ファイルの比較やマージにWinMergeを利用するには以下の設定を行う。

  1. メニューから[ツール(T)]>[オプション(O)]を選択しオプション画面を表示する
  2. オプション画面でツリーから[ソース管理]>[設定を行うソース管理ツール]を選択する
  3. [ユーザツールの構成(C)]ボタンをクリックする
  4. [追加(A)]ボタンをクリックして、【比較の設定】、【マージの設定】を行う

比較の設定

拡張子:”.*”
操作:”比較”
コマンド:”C:\Program Files\WinMerge\WinMergeU.exe”
引数:”/wl /wr /dl %6 /dr %7 %1 %2″

マージの設定

拡張子:”.*”
操作:”マージ”
コマンド:”C:\Program Files\WinMerge\WinMergeU.exe”
引数:”/wl /dl %6 /dr %7 %1 %2 /o %4″

引数の説明

/wl:左ペインを読み取り専用として開く
/wr:右ペインを読み取り専用として開く
/dl:左ペインの比較対象のファイル/フォルダの概要
/dr:右ペインの比較対象のファイル/フォルダの概要
/o:マージした結果ファイルを保存するフォルダ
%1:元のファイル
%2:変更されたファイル
%4:マージされたファイル
%6:元のファイルラベル
%7:変更されたファイルラベル

 

Eclipseでソースコードをコメント化するショートカット

Javaのコメントには次の3種類がある。

(1)「//」以降、行末までをコメント化する形式
(2)「/*」と「*/」で対象を囲む形式
(3)「/**」と「*/」で対象を囲むJavadoc用のコメント形式

Eclipseでは、(1)と(2)についてショートカットキーを用意している。

 

(1)のコメント形式

コメントの始まりを示す // は、行頭でも、行の途中でも入力することが出来る。

Eclipseでは、行頭に // を追加するショートカットキーを用意している。

コメント化したい行にカーソルを移動して、 CTRL+/ を入力する。(なお、 CTRL+7 でも同じことが出来る)

また、行頭で // によりコメント化されている行にカーソルを移動して、 CTRL+/ とすればコメントを外すことが出来る。

複数行を一気にコメント化するには、コメント化したい範囲を選択して、 CTRL+/ を入力する。

【ショートカットを使ったときの細かな動作】

1.行頭からスペースやタブでインデントをつけており、その後ろに // がある場合、その // は「行頭にある」と判断される。

その為、この状態で CTRL+/ とすると、コメントが外れる。

2.行頭に // のある行と // のない行を一緒に選択して CTRL+/ とすると、コメント化される。

すなわち、行頭に // のある行では、さらに // が付加されて //// となる。

 

(2)のコメント形式

この形式は、複数行に渡るような長いコメントであっても、最初と最後の位置だけ入力すれば済むという特徴がある。

Eclipseでは、この「/*」と「*/」を追加するショートカットキーを用意している。

コメント化する範囲を指定して、 Ctrl+Shift+/ を入力する。

コメント化されると、その範囲内の文字が変化する。

コメントを外すときには、すべての範囲を選択する必要はなく、範囲内の一部を選択した後、 Ctrl+Shift+\ と入力すればコメントを外すことができる。

「//」以降から行末までをコメント化する形式のショートカットキー Ctrl+/ との違いは、

・Shiftキーも押す必要がある
・コメントを外すときは、/ ではなく \ (バックスラッシュ)を使用する

【ショートカットを使ったときの細かな動作】

1.コメントの先頭「/*」のある行で改行キーを入力すると、新しく作成された行の先頭に「*」が自動で付加される。

Ctrl+Shift+\ でコメントを外すと、自動で付加された「*」が残ったままになってしまい、コンパイルエラーを引き起こす。

頻繁にコメント化したりコメントを外す場合には、 // を使用する方が便利。

2.ショートカットを使用すると、コメントがネストするのを防いでくれる。

すなわち、 「/* /* */ */」 のようなコメントは入力できないようになっている。

入力ミスを防ぐという点でとても便利な機能。

 

EclipseのJava開発環境構築手順(Pleiades All in Oneパッケージ)

EclipseのJava(Servlet)開発環境構築の手順は大きく分けて2つ。

「Pleiades All in Oneパッケージ」(Windowsのみ)を使用する方法と必要なソフトウェアを個別にインストールする方法がある。

今回は、「Pleiades All in Oneパッケージ」を利用した環境構築手順。

「Pleiades All in Oneパッケージ」は、日本語化プラグインやJDK、Tomcatなど必要なものは同梱されており、解凍すればそのまま使用することができる。

なお、今回の環境は以下の通り。

Windows 7 Home Premium SP1(64bit)

Eclipse 4.4 Luna

JDK-7u15

Apache Tomcat 7.0.59

 

Pleiades All in Oneパッケージのダウンロード

Pleiades公式サイトから目的のバージョンを選択し、ダウンロードする。

Javaの「Full Edition」を選択すると、JDK、Tomcatが同梱されている。

ダウンロードしたZIPファイルを適当なディレクトリに解凍する。

今回は「C:\Pleiades」に解凍した。

 

JDKの環境変数Path設定

対象バージョンのJavaのbinディレクトリ「C:\Pleiades\java\7\bin」を環境変数Pathに設定する。

 

EclipseでJDKの設定

「C:\Pleiades\eclipse\eclipse.exe」を実行し、Eclipseを起動する。

起動時Eclipseで作成したファイルを保存する場所(workspace)を聞かれるが変更しない場合は、デフォルトのままでOK。

起動時何度も聞かれたくない場合は、「この選択をデフォルトとして使用し…」にチェックを入れておく。

メニューバーの「ウィンドウ」⇒「設定」を開く。

左側の一覧から「Java」⇒「インストール済みのJRE」を開き、以下の設定を行う。

インストール済みのJRE…ロケーション「C:\Pleiades\java\7」の「java7」にチェック

 

EclipseでTomcatの設定

メニューバーの「ウィンドウ」⇒「設定」を開く。

左側の一覧から「Tomcat」を開き、以下の設定を行う。

Tomcatバージョン…「バージョン 7.x」を選択

Tomcatホーム…「C:\Pleiades\tomcat\7.0」を設定

左側の一覧から「Tomcat」⇒「JVM設定」を開き、以下の設定を行う。

JRE…「java7」を選択

 

パースペクティブを開く

最後に、パースペクティブが初期状態では「Java」になっているので、「Java EE」を開く。

メニューバーの「ウィンドウ」⇒「パースペクティブを開く」⇒「その他」で「パースペクティブを開く」を開く。

一覧から「Java EE」を開く。

すると、ツールバー上にTomcatプラグインの「Tomcat起動、停止、再起動」のアイコンが表示される。

 

Tomcatの起動

「Tomcat起動」のアイコンをクリックすると、Tomcatが起動される。

コンソールビューが開き、「Server start up in #### ms」(####は状況によって違う)と表示されれば、EclipseからTomcatの起動が成功。

ブラウザで「http://localhost:8080/」に接続するとTomcatにアクセス出来る。

 

Eclipseで設定を別ワークスペースに引き継ぐ

Eclipseでは、ワークスペースごとに設定情報が保存される。

別のワークスペースでも同じ設定を利用したい場合、以下の方法で引継ぎが可能。

【設定のエクスポート】

  1. メニューのファイル>エクスポートを選択し、エクスポートウィザードを表示
  2. エクスポートウィザードで一般>設定を選択し、「次へ」ボタンをクリック
  3. 設定のエクスポートウィザードで「すべてエクスポート」が選択されていることを確認し、「宛先設定ファイル」に設定ファイルの出力先を直接入力するか、「参照」ボタンから指定し、「完了」ボタンをクリック

 

【設定のインポート】

  1. メニューのファイル>インポートを選択し、インポートウィザードを表示
  2. インポートウィザードで一般>設定を選択し、「次へ」ボタンをクリック
  3. 設定のインポートウィザードで「ソース設定ファイル」にエクスポートした設定ファイルを指定し、「すべてインポート」が選択されていることを確認し、「完了」ボタンをクリック

 

なお、起動構成についても同様の手順でエクスポート、インポートが可能となっている。

※起動構成の場合は、ファイル名の指定はない(「プログラム名.launch」が自動で設定される)。